Geyser Addon Update

This guide will explain how to prepare your server for the Geyser Addon if you starting using your setup before the Geyser Addon was released.

NOTE! This guide is only for users who have downloaded one of our setups before the Geyser addon was released! (06-06-2024). If you want to use the Geyser Addon and have downloaded one of our setups before 06-06-2024, we highly recommend downloading the latest version of the setup you are using and starting from scratch!

Why do I need this update?

If you want to purchase our new Geyser Addon to allow Minecraft Bedrock players to join, you have to follow this guide for the Geyser Addon to work on your server. This is because we have made a lot of changes to our setups to make the Geyser Addon work. So the Geyser Addon will not work out of the box if you have started using our setups before 06-06-2024.

This update will change all of the Custom Texture Glyph symbols in the setup. It will change all glyph symbols in the Holograms, Menus and in the Chat.

Update Guide

1. Download latest setup version

Start by downloading the latest version of the setup you are using. You will need the new files in this setup to update the files on your server. You can download the latest version of the setup directly on BuiltByBit.

2. Update the setup resourcepack

Update the resourcepack on your server to the latest version of the Premium Setup resourcepack. To do this, replace the file at this filepath on your server with the one at the same filepath from the latest version of the setup: plugins > ForcePack > config.yml

3. Updating DecentHolograms

Change all of the holograms on your server to the holograms from the latest version of the setup. To do this, locate this folder on your server and in the latest version of the setup: plugins > DecentHolograms > holograms

In here, delete all of the hologram files on your own server and replace them with the hologram files from the latest version of the setup you are using.

4. Updating TAB/Scoreboard

Change the TAB config on your server. To do this, locate this file on your server and in the latest version of the setup: plugins > TAB > config

Now replace this file with the same file from the latest version of the setup you are using.

5. Updating Tags

All of the tags has to be updated. To do this, locate this folder on your server and in the latest version of the setup: plugins > DeluxeTags

Delete the DeluxeTags folder on your server and replace it with the DeluxeTags folder from the latest version of the setup you are using.

6. Updating ChatGames

The ChatGames configs has to be updated. To do this, locate this folder on your server and in the latest version of the setup: plugins > ChatGames

Delete the ChatGames folder on your server and replace it with the ChatGames folder from the latest version of the setup you are using.

Now locate locate this file on your server and in the latest version of the setup: plugins > Skript > scripts > emojis.sk

Now replace this file with the same file from the latest version of the setup you are using.

7. Updating ChatEmojis

The ChatEmojis configs has to be updated. To do this, locate this folder on your server and in the latest version of the setup: plugins > ChatEmojis

Delete the ChatEmojis folder on your server and replace it with the ChatEmojis folder from the latest version of the setup you are using.

8. Updating InteractiveChat

The InteractiveChat configs has to be updated. To do this, locate this folder on your server and in the latest version of the setup: plugins > InteractiveChat

Delete the InteractiveChat folder on your server and replace it with the InteractiveChat folder from the latest version of the setup you are using.

9. Updating Scripts

The scripts with Custom Texture Glyphs has to be updated. To do this, locate this folder on your server and in the latest version of the setup: plugins > Skript > scripts

In here, select these files: linkdiscord, linkstore, linkvote, motd

Now replace these files with the same files from the latest version of the setup you are using.

10. Updating Essentials Kits

Change the Essentials Kits config on your server. To do this, locate this file on your server and in the latest version of the setup: plugins > Essentials > kits.yml

Now replace this file with the same file from the latest version of the setup you are using.

11. Updating DeluxeMenus

Now you have to update all the DeluxeMenus menus where custom texture glyphcs has been used. We will do these one by one.

First locate this folder: plugins > DeluxeMenus > gui_menus > tags (nationtags if you are using the earth setup)

Now replace this folder with the same folder from the latest version of the setup you are using.

First locate this folder: plugins > DeluxeMenus > gui_menus > ranks

Now replace this folder with the same folder from the latest version of the setup you are using.

First locate this folder: plugins > DeluxeMenus > gui_menus > levels

Now replace this folder with the same folder from the latest version of the setup you are using.

12. Updating LuckPerms prefixes

Now you have to update all the symbols used for the LuckPerms prefixes on your server. To do this, start by opening the LuckPerms editor on your server. You can do this with the command "/lp editor".

In here, you have to open the permissions for all the ranks and levels, and replace the symbol used for the prefix with the symbols shown below.

Member: 
Knight: 
Lord: 
Paladin: 
Duke: 
King: 
Youtuber: 
Streamer: 
Helper: 
Builder: 
Mod: 
Srmod: 
Admin: 
Dev: 
Manager: 
Owner: 

1: 
2: 
3: 
4: 
5: 
6: 
7: 
8: 
9: 
10: 
11: 
12: 
13: 
14: 
15: 
16: 
17: 
18: 
19: 
20: 
21: 
22: 
23: 
24: 

13. Adding Geyser Shop

The latest versions of our setup has a shop specifically for Geyser players as Geyser players can only left-click. To add the Geyser Shop to your setup, locate these folders: plugins > DeluxeMenus > gui_menus > geyser_buy_shop & geyser_sell_shop

Add these 2 folders to your own setup. Then locate this file: plugins > DeluxeMenus > config.yml

Now replace this file with the same file from the latest version of the setup you are using.

Then locate this file: plugins > Skript > scripts > shopcommand.sk

Now replace this file with the same file from the latest version of the setup you are using.

Last updated